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Microsoft Access

Materials Required for Module 4
r Microsoft Access Getting Started 

r Microsoft Access User's Guide

r Address Book database project

Module Objectives

Lesson 1 - Creating a Form

Upon completion of this lesson, you will be able to:
r Create a form with a Wizard.

r Add, delete, and insert records in both Form View and 
Datasheet View.

Lesson 2 - Customizing a Form

Upon completion of this lesson, you will be able to:
r Create a two column list box on a form.

r Create and format controls.

r Create form headers and footers.

Lesson 3 - Designing a Form

Upon completion of this lesson, you will be able to:
r Create bound, unbound, and calculated controls.

r Create option groups.

r Set field, section, and form properties.
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Lesson 1

Creating a Form

Reading Assignment

r Microsoft Access Getting Started 
Chapter 4: Creating a Form

As You Read

r Using a spreadsheet to enter or view data can be tedious.  
There is no room for hints to help the user and important 
data does not stand out. Most users prefer a customized 
form that might include graphics, list boxes, calculated 
fields, and data from multiple tables.  These features make 
data entry faster and information in the database more 
meaningful.  What are some forms that you use often?

Hint:   Eforms 

Order Entry
Applications
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Tax Forms
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Exercises

1) How many Form Wizards are there?

Four.

2) When you move to the last record using the navigation button, why is there still one more
record below?

See page 64- There is always a blank form or record to add more 
data.

3) What symbol signifies the current record in form view?
A solid right pointing arrow.

4) Where, in a form, does Microsoft Access display the information you entered for the field
description when you created the table?

See page 64-  In the Status Bar.

5) How do you save a record without leaving it?

See page 64-  Choose the Save Record command from the File Menu.

Try This

1) Open the NWIND database and then the Customers form.

2) Switch to Datasheet View.

3) Go to the end by clicking on the Last Record button and then clicking the Next Record 
button. 

4) Enter the new customer information: PSS, Product Support Services, Patty Stonesifer, 
General Manager, One Microsoft Way.

5) Tab to the City column and type Renton but do not hit enter.

6) Oops!  That's wrong.  You wanted to enter Redmond.  Press esc.  What happens?

7) Press esc again.  Now what happens?

8) What is the menu equivalent of pressing esc the first time? 

The second time?
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9) Once you have canceled either a field or a record entry, can you undo your cancellation?
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Lesson 2

Customizing a Form

Reading Assignment

r Microsoft Access Getting Started 
Chapter 5: Customizing Your Form

As You Read

r Each control in a form inherits the properties of the field 
that it is based on.  However, you may override these by 
specifying formats, defaults, and rules that are specific to 
each form you create.  If you were designing an expense 
report form for 10 different product support managers, 
what defaults would you allow them to customize?

Hint: department number
Name
Date
Reason
Amount
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Exercises

1) Can you drag controls from the Detail section to the Header section using the mouse?

See page 74- Yes.

2) If you draw a selection marquee around several fields in the Ping-Pong Player Form but do 
not select their labels and then choose Align Right from the Layout menu, what happens to 
the alignment of their labels?

See page 80-   The Labels do not reflect the alignment change.  Make 
sure you select the control text box not the label too.

3) How do you shadow a control? 

4) On page 87, you were shown how to create a two column list box for choosing player skill 
levels.  The values for the list box are separated by semi-colons.  What happens to these 
values if you change the Column Count property to 3?

See page 87-   The values are wrapped to three columns.

5) How do you set a default value for a control on a form?

See page 88-  Choose the control in Design View and choose the 
Properties tool.  Change DefaultValue property.

Try This

1) Open the NWIND database and then the Categories form.

2) How many products are there in the Dairy Products category?

10.

3) Switch to Design View.

4) What type of object displays the Datasheet View of the products that are in each category?

The Category Sub-form.

5) Click on the Properties button on the Toolbar.

6) What table is the embedded subform based on?

The RecordSource is the Products Table.

7) The Link Child Fields and Link Master Fields properties indicate the field that the main form
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and the sub-form have in common.  In this example, Microsoft Access looks at the Category 
ID of the current record in the main form.  Only those records that have this Category ID are 
displayed in the subform. 
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Lesson 3

Designing a Form

Reading Assignment

r Microsoft Access User's Guide 
Chapter 9: Designing Forms

As You Read

r This chapter contains an example that uses a dynaset (the 
results of a query).  We have not covered queries yet, but 
you will understand the example if you remember that a 
dynaset functions much the way a new table does.   



Exercises

1) What is the difference between bound and unbound controls?
See page 3- Bound control both gets and stores is value in a field in a table or query.  
An unbound control is not connected to a field.

2) What properties are inherited from the table for a bound control?
See page 4-  Format, DecimalPlaces, StatusBarText, ValidationRule, 

ValidationText, DefaultValue, and Caption. 

3) If you change the Default Value property for a field in a table, will that change be 
reflected in existing Forms?

See page 10-  No, you have to update the properties on the forms yourself.

4) How do you start a new line in a multiple-line text field?
See page 9 -  CTRL + Enter.

5) If you have Combo Boxes and List Boxes on your form, do they display in Datasheet 
View?

Yes and No.  Once you click on them, they behave like Combo or List boxes.

6) In Datasheet View the label portion of a compound control is displayed as the Column 
Heading.  What is displayed as the Column Heading if you delete the label?

See page 12.  It's the Control Name.

7) In a List Box, which property specifies the field that new or updated data will be stored?  
Which property specifies from where the list of choices will come?

See page 23-  The Control Source and the Row Source.

8) How do you hide the Bound Column in a List box?
See page 24-  Set the Width of the column to zero. 

9) What additional functionality does a Combo Box have that a List Box does not?
See page 27-  Using a Combo Box allows the user to add new choices when the 

LimitToList property is set to No.

10) Can you drag existing check boxes or option buttons into an Group Frame to create an 
Option Group?

See page 30-  No, the boxes or buttons must be brought in by using Cut and Paste 
if they are all ready created.
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Exercises

11) How do you control the order that users will tab through the controls on a form?
See page 258-  Choose Tab Order from the Edit menu.  Rearrange the controls in the 

dialog box.

12) How many times will each section of your form appear when you are entering data vs. when 
you print the forms, assuming you are printing one page?

On Screen         Printed
See page 260- 1 1

Form Header: ________         _______

0 1

Page Header: ________         _______
1 1

Details: ________         _______

0 1

Page Footer: ________         _______
1 1

Form Footer: ________         _______

13) How do you set the default view to Single Form?

See page 40-  Choose Edit Select Form and use the properties.  Change 
the Default View to Single Form. 

14) Can you have a continuous master form if there is an embedded sub-form on it?
No, the master form defaults to Single Form view.
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Try This

1) Open the NWIND database and create a new, blank form based on the table Categories.

2) Select Combo Box in the Toolbox.

3) Select the field Category Name and drag and drop it onto your form.

4) Set the following properties:

Row Source Type: Table/Query

Row Source: Categories

Column Count: 2

Column Widths: 0; 1.5

Bound Column: 2

Limit To List: Yes

6) Switch to Form View.

7) What happens if you type in Desserts and attempt to move to the next record?

Error message: "Entered Text must match list entry"

8) Switch to Design View and change Limit To List to No.

9) Return to Form View and go to New Record.

10) Now what happens if you type in Desserts and attempt to move to the next record? 
Hint: Move to new record and view the list of Categories 

Desserts has now been added to the Category list.
How do you get the second form to show the updated list in the Combo box? 
Use the Requery action with a macro.  Otherwise changes in the list are not 
reflected while in Continuous forms.
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In order to enter a new record in your Address Book database for a friend with children, you would have 
to open, modify, and save two different tables.  The goal of this lab is to create a single form that will 
allow you to enter data into one form for both tables.  In later labs you will place a button on your form 
and create a macro to bring up a second form for entering information about pets and hobbies.  

1) The first step is to create the main form.  Select the Main Contacts table in the 
Database Window and press the New Form button.  Choose a blank form.  Drag all 
fields to your form and save it as "New Record Entry."

2) Switch to Form View and verify that your form is working by entering a new record.

3) Now create a tabular form for the Dependents table.  The Categories Sub-form in 
NWIND is an example of a tabular sub-form.

Hints: If you drag all fields to your Detail section, display the Form Header, and draw a marquee 
selection around just the labels, you can cut and paste all labels into the Form Header section.

 

4) After saving the tabular form as "Tabular Dependents Sub-Form", open the New 
Record Entry form in Design View.  (Press F11 to activate the Database Window.)  
Drag the Tabular Dependents Sub-Form onto the New Record Entry form.  MS 
Access will automatically resize it to accommodate the sub-form.  

5) Click on the properties button and verify the following properties for the sub-form:
Link Child FieldsMain Contact ID
Link Master Fields Contact ID

6) Switch to Form View and verify that as you view different records in the main form, 
the correct dependents are displayed in the sub-form.  
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Open the NWIND database and create a form based on Shippers.  Save the form. Create a form based on 
Orders and save it. Drag the first form onto the second.  Select the forms and look at the properties Master
Child fields. Why are they
blank?  Recreate the relationship.  Why are they still blank?  What do you need to do in order to have MS
Access fill in these properties automatically?

The Master Child Fields are blank because the Field names do not match.  If
the Key fields were spelled the same they would show up automatically.  
The relationship between Shippers and Orders is One-to-Many.  Some may 
try to create a One-to-Many from Orders to Shippers.  Stress upon the 
students to think through the problem.

Open the Employees form in Form View.  Tab to the photo field and choose Insert Object from the Edit 
menu. Select Paintbrush.  When Paintbrush comes up change your mind and decide that you do not want
to change the photo.  Close Paintbrush and answer No to the Update MS Access dialog.  Now the photo 
field is blank.  Why?  How do you undo your change?  Hint: How do you undo a change made to any 
other field?

First choose Undo Current Field from the Edit menu.  Then choose Undo 
Current Record from the Edit menu.  The OLE object was being updated 
with a white or blank picture.  The event of choosing Insert Object 
automatically replaces the picture.  The second event of saying No in the 
Server app then leaves the picture blank.

If you select a tool in the Toolbox and make changes to the Property sheet, you are setting the defaults for
that tool.  Does this default affect the current forms, all forms, or only new forms?  Does it affect new 
databases?  What steps do you need to take in order to have all forms (in a new database) have a default 
background color of Red? 
New forms only are affected.  This does not affect new databases.  Import the
default form with the background color of red and set the Form Template 
option to the name of that form.



Instructor Led Module Review
1) Answer Questions

How do you save a record without leaving it?
See page 64-  Choose the Save Record command from the File Menu.

How do you shadow a control? 

How do you set a default value for a control on a form?
See page 88-  Choose the control in Design View and choose the 

Properties tool.  Change DefaultValue property.

Can you have a continuous master form if there is an embedded sub-form on
it?

No, the master form defaults to Single Form view.

2) Review As You Read and Points to Ponder
Why might you give a user access to a form but not to the underlying table?  
Hint: You would only give permission to enter and view records, not to 
change the form design. 

Discuss Validation, ability to delete tables, etc. 

3) Present one or two possible lab solutions.

4) Discuss various participant solutions
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